Can't disable Panic mode or something

Speedy Georgia

New member
Hey guys this is my first post. I couldn't find a search feature to look for this topic, if it's already been answered please direct me to it.

I recently purchased Real Flight trainer edition and first used my Xbox controller to play. I have since borrowed a Spektrum Dx4e tx and bought the Ws2000 dongle. I've successfully paired up the tx and have chosen the Dxe or DSM option for the controller and my inputs come across correctly.

When trying to use the tx I'm able to fly for about 4 seconds before some kind of AI or panic button takes over and the plan turns, lines up with the runway, and lands. I am unable to control anything once this begins. This is very frustrating and I don't know what to do. I tried looking at panic mode which I read was ch 7 but I've tried different configurations and can't find one that lets me fly....

Same.... was working fine a few months ago, came back today, and now can not control planes, since panic mode seems to be permanently enabled. I'm using Spektrum DXs transmitter and non-Spektrum USB dongle. Have tried various profiles, same thing. Help!