G2 Upgrading issues

fuall

New member
Hi I just reinstalled G2 on my PC how ever when i try to update the software i get an error connecting to primary server then same on secondary server i have also updated the control panel.
if anyone could mabe give me an actual file download link id really appricate it or any other help help
 

garleness

New member
i too am having issues

I folled the knoledge base to the console upgrade still doesnt work now it says knife edge sofetware has an error instead of error 183
 

jeffpn

Well-known member
garleness said:
I folled the knoledge base to the console upgrade still doesnt work now it says knife edge sofetware has an error instead of error 183
:confused: Huh? :confused: What are you trying to do?
 

garleness

New member
i was trying to upgrade my software. ive been out of training since i had kids so i was trying to update my g2, upgrades not working, i just found manual 7.23 up grade it worked if there is a later manual upgrade i would love to do that as well.
I didnt realize they had upgraded the program to g5 wow. I have purchased a align t-rex and wanted to fly something close any help would be great thanks
 

garleness

New member
Thanks for the speedy reply can the g2 controller usb be used with g5 or do you have to buy the whole package again. I just want to have some newer models. thanks again for your help
 

swanley007

New member
The G3 controller cannot be used with the G5 upgrade. It must be the Interlink Plus or Elite to work with the G5 upgrade.
 

jeffpn

Well-known member
You made a typo, swanley. The G3 controller can be used in G5. The G2 controller cannot be used in G5.
 

Bodhammer

New member
I have version 2.00.637 - is that the latest/last?

A buddy gave me the kit, just wanted to make sure I was fully updated. The control panel update could not connect to any servers.

Thanks!
 

Norton

New member
Bodhammer said:
I have version 2.00.637 - is that the latest/last?

A buddy gave me the kit, just wanted to make sure I was fully updated. The control panel update could not connect to any servers.

Thanks!

It is a discontinued product, there are no servers to connect to.
I'm not sure what the latest version was, good luck.
 

AndyL

New member
I own G2 and would like to be able to update it to the newest version. The update servers of course don't work.

Can someone please send me a link to the update file?

Thank you very much.

Andy
 

jeffpn

Well-known member
AndyL said:
I own G2 and would like to be able to update it to the newest version. The update servers of course don't work.

Can someone please send me a link to the update file?

Thank you very much.

Andy
Sent
 

swolf

New member
AndyL said:
I own G2 and would like to be able to update it to the newest version. The update servers of course don't work.

Can someone please send me a link to the update file?

Thank you very much.

Andy

I need the same link
Steve
 

jeffpn

Well-known member
Send a PM to AndyL. I don't have it handy. If you call tech support, they can also give it to you.
 

Lightning1958

New member
I have the G2 lite version that worked fine on windows xp.Now I have a computer with windows 7 and it refuses to load.Any ideas on how to fix this problem.I would hate to change vendors. thanks Lightning1958.
 

maxkop

Well-known member
Tried compatibility mode? (Right Click on .exe or setup file -> Compatibility -> winxp (service pack 3; at least that would I try first) The installation worked ???
 

Monbonlupin

New member
Hi, I own G2 version 2.00.219. After installation, I end up with a white screen with sound. How can I upgrade to the latest version ? Of course, the server doesn't respond.

Thank you
 
Top