Loading Error on Windows 10


New member
I have RealFlight G3 and I recently got a new laptop with windows 10. I loaded G3 from the CD and it loaded fine. Then I tried to download the G3.5 upgrade. The download would start and run for a long time but wouldn't complete. So I thought I would uninstall G3 and reload it and try the upgrade again after the fresh load. So I tried to uninstall G3 and it didn't seem to uninstall correctly from the Realflight control panel. I then went into windows uninstaller and unistalled realflight from there.

Now I tried to reinstall G3 from the disc and I get an error message saying "This program has been damaged, possibly by a bad sector of the hard drive or a virus. Please reinstall it." I have run my virus scan, run disc cleanup and defrag, I have deleted any files from the day I installed G3, rebooted my computer numerous times and I still get that same error message everytime I try to load from the disc.

Has anyone else run into a problem like this? I guess I should have left G3 on the computer and not worried about the 3.5 update. Any help would be greatly appreciated.


New member
I have work around for the This program has been damaged, possibly by a bad secto-

If your on windows 10, run realflight g3 in compatibility mode for windows xp, to do that, just right click on the setup and click on properties and then click compatibility, then from there you should know what to do because i'm going to bed hence my name.