Manual updates for RealFlight G2

Ryan Douglas

Administrator
Staff member
RealFlight G2 was discontinued a long time ago. Several years after that, the G2 registration server failed beyond repair, and because the product had reached end of life, that meant the end of online updates availability.

We still get occasional requests for the standalone manual updates for RFG2. Attached to this post are all of the ones we still have lying around. There were updates for earlier versions, too, but they have been lost to the mists of time.

We are releasing these as is. Like G2 itself, they are completely unsupported.

I believe each of these files was designed to only update from the previous version to the version specified in the file name. So if you already have 2.00.637, you would need to install RealFlight2_00_717.exe and then RealFlight2_00_723.exe in order to update to version 2.00.723. But I'm not positive about that. I didn't install these myself to see exactly what they do. It's been eleven years since I made them, so I can't remember for sure. Maybe you really only need the last one?

To use:
  1. Download the attached file(s).
  2. Rename the file(s) to remove the ".rfx" extension (that part is only present to allow the files to be uploaded here). Ex: "RealFlight2_00_723.exe"
  3. Run whichever one(s) you need for your installed version of G2 (see my comments above). You'll probably need to run as admin.
If things go badly, you should be able to uninstall G2 and reinstall from your RealFlight CD to get back to where you were before.
 

Attachments

  • RealFlight2_00_637.exe.rfx
    7.2 MB · Views: 265
  • RealFlight2_00_717.exe.rfx
    7.2 MB · Views: 262
  • RealFlight2_00_723.exe.rfx
    7.2 MB · Views: 276
Last edited:

gcdesroches

New member
Windows 7 note

A note on the above: These files will not run on Windows 7 64bit. Even if run in XP compatible mode as admin they will error out. Sorry boys and girls.
It should be noted though: I was able to install from CD using XP SP3 compatibility, I just could not use these update files.

I do not know if the same issue would occur using Windows 7 32bit. You could try it... Let us know back here ok?
 
Last edited:
I'm currently running Xubuntu 18.04. I have Windows XP Pro running in VirtualBox 5.2.42. I just tried installing RealFlight2_00_723.exe. The Attached Screen Shot shows the results.
 

Attachments

  • VirtualBox_Windows XP Pro RealFlight Test 1_04_07_2020_18_26_42.png
    VirtualBox_Windows XP Pro RealFlight Test 1_04_07_2020_18_26_42.png
    1.5 MB · Views: 21
Top