Planes don't respond to controls, auto level and fly by themselves

Donity

New member
Hey all.
I've had a problem with the realflight trainer edition carbon cub, the habu jet, and some other aircraft. For some reason, after a certain amount of flying, it annoyingly stops me from putting control inputs and flies by itself.

How do i stop this
 

Ryan Douglas

Administrator
Staff member
@Donity, what you're describing sounds like the "virtual fence" SAFE feature that prevents a model from getting too far away. When the plane exceeds a certain distance from its starting point, it takes over control, turns itself around, holds straight and level flight for a few seconds, then wags its wings as a signal to the pilot before relinquishing control.

Both the E-flite Apprentice STS 1.5m (with LAS and GPS) and the HobbyZone Carbon Cub S+ 1.3m have that feature enabled. The distance thresholds are 150 meters and 100 meters, respectively. I believe those are the only two models in RealFlight Trainer Edition (I don't expect to see it on the Habu which you mentioned), but if I'm wrong you'll of course be able to clearly recognize the behavior if it occurs elsewhere.

In the full version of RealFlight you can edit models to make all kinds of changes, including turning off that virtual fence behavior. The aircraft editor is an advanced feature that is not present in Trainer Edition, though.

One of the most important skills for a new pilot to learn is the ability to fly within a constrained area. It is far too easy and far too common for beginners to let the model get farther away than they realize, which can be disastrous. Rather than get frustrated by those limitations, I encourage you to let them help you form good habits.

Most of the models offered in RFTE--including other variants of the Apprentice STS--do not employ that particular SAFE feature. You can fly those unrestricted. As you advance, you may find you want the vastly increased selection of models and the ability to edit that are part of the full RealFlight 9.5S edition.
 

Speedy Georgia

New member
I'm having this same problem but the area I can fly in is super small. This didn't occur when I used an Xbox controller as my tx, but now I'm using a dx4e and dongle. I can't figure out how to disable this either. It's impossibly frustrating to fly for 4 seconds and lose control of the plane until I reset the plane...
 

Flapper

Active member
Not having 9.5 or those controllers, I'd suggest you hook up your xbox controller, verify it is working correctly, and then go into the RF Controller menu and take a look at what controls/buttons are being mapped to what. Then do the same after switching to the dongle. Odds are that there is one (or more) functions not being mapped, and you therefore cannot turn off the geofence. A little adjusting will get you a custom configuration that you can then continue to use.
 

scaler123

New member
I'm having this same problem. Let me give more info...
Real Flight Trainer Edition was working fine a few months ago. Using it with DXs transmitter, and a non-Spektrum dongle that seemed to be working fine. I came back today to try the simulator out again, and noticed the same behavior. In my case, the problem seems to be that the Panic feature is permanently enabled, with no way to disable it. Panic mode seems to take away all control, and auto-lands the plane. Have to hit spacebar to start over.

Anybody have any idea how to disable panic? Seems to be a change in programming of the simulator, since I didn't (that I know of) change anything on my end.

Thanks in advance!
 

Kenta78

New member
My friend has a DXs too and on his transmitter Button C enables Safe mode. It might be somehting you need to change in the radiosettings in RF. Also using a dongle might cause the issue, as you can only use 8channels max. The Interlink DX gives you alot more channels to play around with, it´s expensive yes..but gives you the most out of the simulator really. :)
 
Top