Real Flight Evolution does nothing

Lowen99

New member
I purchased Real Flight Evolution from Horizon Hobby today. I was able to download Steam and RFE successfully without any errors. I am using my NX 10 transmitter with USB connection to my Samsung Laptop. I have tried to launch from the desktop icon and steam. It takes me to this screen and I am unable to go any further. I watched a video and my transmitter is set up correctly. The video I watched said to click esc on my laptop and it would take me to the homepage but that and nothing else has gotten me past this screen. Any help would be appreciated.

1669408407326.png 1669408608327.png
 
Last edited:

asj5547

Well-known member
I see you have a 12th generation CPU, see the link below.
Does your laptop have integral GPU or do you have dedicated GPU? if you have dedicated make sure that is what your PC is using.

 

Lowen99

New member
I see you have a 12th generation CPU, see the link below.
Does your laptop have integral GPU or do you have dedicated GPU? if you have dedicated make sure that is what your PC is using.

Thank you for the response. I am using a laptop and I am not sure how to determine if my GPU is decdicated or integral. I went to my graphics settings and changed the default and that did not work. Custom options does not even see RFE so I guess I am out of luck until Intel updates their drivers. If anyone else knows of a setting I can try it would be greatly appreciated.
 
Last edited:

flightengr

Active member
You can go to the Start menu and run a program called "Device Manager". That will show you the make/model of CPU under "Processors", and the type of graphics you have under "Display Adapters".
 

Lowen99

New member
I did that but I am not sure which one mine is using and if I have the ability to choose which one and if it would make a difference.

1669476342740.png
 

Lowen99

New member
I hit ESC on my keyboard and I was able to fly the default airplane but that is it. Great game and graphics, just wish I could do more. Looking forward to the fix.
 

asj5547

Well-known member
Press the "Esc" key and scroll down the list, click on "Settings"
Click on Graphics,
Click on Hardware,
Click on Graphics Adapter, hopefully you see an integral and dedicated listed, so you can make a choice.
 

technoid

Well-known member
You might try this if you're comfortable with using the console.

Open the Console by hitting the tilde key "~"
In the Console type showlegacymenu and hit enter.

That should enable the normal "old" menu at the top of the RealFlight Evolution Window. If you see it you can try loading planes the old way.

Click on the Aircraft menu.
Click on the Select Aircraft menu item.

Then select a plane from the dialog box that opens. Let us know if that works.
 

asj5547

Well-known member
If the ~ key does not work, go to documents/Realflight Evolution/Scripts folder and double click on the "startup.rfscript" file and add a line,
showlegacymenu, like I did, (see pic).
Restart RFE to see the legacy menu (looks the same as RF9.5)
Now you will be able to go to the top left corner of the screen and click on "Simulator" scroll down to select Settings, Graphics, hardware.
 

Attachments

  • show legacy menu.jpg
    show legacy menu.jpg
    108.5 KB · Views: 17

flightengr

Active member
I did that but I am not sure which one mine is using and if I have the ability to choose which one and if it would make a difference.

View attachment 132264
It looks like you have a second monitor plugged in in addition to the built-in screen on the laptop. Or, if you don't have two screens, then you may have a docking bar that is connected to the computer via USB but maybe adapts to an HDMI or DisplayPort port. That's why you have a second adapter listed.

I'd try unplugging the extra stuff and see if the game will play with the monitor that's built into the laptop.
 

Lowen99

New member
If the ~ key does not work, go to documents/Realflight Evolution/Scripts folder and double click on the "startup.rfscript" file and add a line,
showlegacymenu, like I did, (see pic).
Restart RFE to see the legacy menu (looks the same as RF9.5)
Now you will be able to go to the top left corner of the screen and click on "Simulator" scroll down to select Settings, Graphics, hardware.
That did it! You sir are a genius.
1669557130253.png
 

Lowen99

New member
It looks like you have a second monitor plugged in in addition to the built-in screen on the laptop. Or, if you don't have two screens, then you may have a docking bar that is connected to the computer via USB but maybe adapts to an HDMI or DisplayPort port. That's why you have a second adapter listed.

I'd try unplugging the extra stuff and see if the game will play with the monitor that's built into the laptop.
Yes, I am running dual monitors through a docking station. It seems to be working good now. Maybe once Intel fixes the other issue I will be able to use the new menus. Its all good though, I am not much of a gamer, I just bought this to keep the rust off over the winter. I appreciate all of the help with my problems. Happy Holidays to all!
 
Top