Realflight 7.5 with windows 11


New member
i read that there was a Problem with the Realflight evolution with Windows 11 and direct X

Does the old Realflight run on windows 11 or will there be an update?

Best regards

No issues with Windows itself...but....
Originally, Evolution (and most older versions) used DirectX 9. Some GPU's dropped support for it. And built-in graphics on newer Intel chips also would not run Evolution. Evolution has now been fixed to use DX 11, so those are no longer issues.
You may still run into them, though, when trying to use a DirectX 9 only version (like 7.5) with a GPU or CPU that doesn't support it anymore. So, a hardware incompatibility issue, and not a Windows issue. With any Nvidia brand GPU you will always be fine. But do not plan on any updates to make old versions run on hardware it can't currently run on.
Something must have been worked out because I just installed all my old versions including 4.5 - 5 and 7.5 , Evolution plus expansion packs on my new 13th gen i9 RTX4080 laptop, maybe it’s because I appointed the dedicated gpu to the app but I just stuck the disk in and let er rip.
Please direct me to where i need to go for help. I recently retired from teaching. I had RF 7.5 installed at school so the students and I could use it. We had a Aviation class on our campus. The box the disc came in did not make it home. maybe a janitor threw it away or it just got moved somewhere. I'm trying to set up on my desktop computer with a 32" screen and I need that code that is on the box i don't have. What do i do? Thanks.
@Cantland, that is quite unfortunate. You really do need both the serial numbers, the RealFlight serial from the DVD case and the controller serial (which presumably you have).

Did you register the software under your name? I don't know if you could provide sufficient evidence for RealFlight Product Support to potentially retrieve it, but that might be worth a try.

You could consider purchasing the software-only version of RealFlight Evolution. It sounds like you still have your controller, so you could save that cost at least.
This is probably the best thread to hop on to. I recently installed RF4.0 (CD version) on my 4k screen gaming laptop with an Nvidia card. I did not install DX9 since I thought there would be backwards compatibility and did not want to risk some type of downgrade. I am currently running DX12. The current issue I am having is I can change planes just fine, but RF crashes when changing airports. It worked fine at some point after the install because I am not at the stock airport anymore. The issue may have came after I installed EP1 and EP2 or possibly tweaking the graphics settings or try and get full screen to 4k or maybe after I installed RF Evolution. I don't remember if I clicked yes to the DX9 agreement or not, but I know I did not install it. I may have hit cancel right away. I tried copying my RF 4.5 installation from a previous computer HD from the Data to Data locations. As best I can tell that worked to upgrade to 4.50.050 (2012). It appears I have 4.5, but that did not fix the issue.

When installing RF 7.5 from DVD, I saw a message to accept the DX9 agreement even if you did not install it. 7.5 DVD version and the last update had no issues when changing airports or planes.

On a side note / similar issue, I tried installing RF 4.0 on an old computer for a club house so friends could play if I brought my controller. We have a large 4k TV perfect for RF. There were no issues with that install changing planes or airports, but although the computer displayed 4k fine, RF was not smooth at 4k even when turning the graphics down and running at 1080. I think it had Win 10 and maybe DX11. It has me wondering if this might have been an issue with DX9 not being installed?
@pkquat, there came a point where RealFlight required certain additional helper components from DirectX 9, making that installation step necessary even on computers that already had the core DX9 installation, or indeed DX11 or 12. But two things: 1) I think that requirement came in after G4.5, and 2) RealFlight would display an error message on startup and simply refuse to run if those components were missing. But it's possible way back with G4 the issues manifested a little more subtly. It's been a long time and my memory is getting a little hazy about that.

Best to simply perform the installation. It will do no harm. You don't need to worry about it doing anything weird to later DirectX versions. You can manually trigger the DX9 installation by inserting the highest numbered G4 disk you have (with earlier CD versions, this should be #4), navigating into the "DIRECTX" directory, and running DXSETUP.EXE.

Another possibility that comes to mind is driver issues. Make sure you have the correct, latest driver installed for your graphics adapter.

It's also possible something got corrupted in your RealFlight .ini or with a custom airport. Try going to your <Documents> directory and temporarily renaming the "RealFlight G4" directory. This will reset everything to defaults the next time you try to run. If it ends up helping, then you can get more selective about discarding only specific things if you care, but it would be a good way to quickly narrow things down a bit.

I do not recommend copying a RealFlight installation from one location to another. You should reinstall from disk and perform online updates. (Feel free to copy the OnlineCache dir to the new installation, though, prior to online updates. It might save you a lot of downloading, and this is safe.)

Re: performance at the clubhouse, there are many variables here. 4K is far more demanding than 1080p. I don't know anything about the specs on that PC, or whether it's working correctly. Sometimes TVs have modes that interfere. That's tough to address this far removed.