Compatibility issue with older CPUs

Finally got the new disk today. Worked fine. I imported the trex450SE from this site and its great. I need to tone it down a bit as soon as I learn how but the physics are very good just more responsive than my real ones. May be the motor etc.

On install it asked for the serial and interlink number but never asked me to register so I can get any future updates when available. How do I register?

Hope everyone gets up and running real soon. :)
Actually, if you knew how to update, you'd see how to register. ;) Check the RF launcher, Additional Options
well mine came in and to my pleasant suprise it worked like a charm even with my old cpu, must have got a new version, also found my old g3 controller which i read some people had problems with, so im impressed, it flies much more realistic on advanced, the 3.5 with bigger custom planes felt more like a blimp than a plane, was kinda rediculous actually, and took about 5 minutes to get a torque roll, much niser now for sure, i do have to figure out my frame rate though, toned it down to similar specs to my 3.5 and its sill only mid 40s-70s, its livable when in the 70s, but same field and similar settings my 3.5 was 70-90 and was better, i could post my specs here if you want or i can start another thread if its not technically the right place, im going to try some more adjustments and check back later
well i just lowerd my pixels on my monitor to 1024 by 728 i think it said, was one step up at 11 or 12 something by something else, that did help, now in 60-80 and hit 92 once or twice, just have to get used to the rest of the appearance, im my computer the folders and icons are bigger than they were, seems wierd but i guess i can learn to like it, especially if i get better performance all around
If you fly RF full screen, you can adjust the res inside of RF and put the Windows res back to where you had it.
Last edited:
that worked out, thanks, unrelated, i did and uninstall of my 3.5 from the launcher, says it was gone, but looking in my add/remove programs g2 still shows up? i never even had g2, should i remove that from there or is that something basic that needs to be there to run my 5, which shows up right under that in the list
I have 4.5 and G5 installed, seperate folders for each. I have no G2 folder. Delete it, if you wish. If G5 starts acting weird, which I doubt, simply reinstall G5.
well that was wierd, it was in control panel-add/remove programs, i clicked to remove and it poped up saying not installed and no serial number, clicked okay and now its gone, wacky, it still showed mb's on my disk thats why i was asking to free up space, guess its taken care of now
Different Build same problem

Taking time to build my game scream machine (XP move issues) so I got the G5 build 500.27 disk replacement for my build 500.18

Problem is different builds, same error issue: "KE software installer has encountered a problem and needs to close"

Anyone know if this error is older CPU related (mines AMD Athlon) or am I PC hades until new machine's on line???

Thanks all :confused:
installing wind 32 app error

i get a wind 32 app error when i try to install the disk i have intel pentium processer D is this older then 3. I do not know much about pc so this is very confusing for me. What does not a win 32 app stand for anyways
and how do i fix this problem? i already bgrought some pc repair crap that soppoused to fix win 32 error but it still pops up
Last edited: