Potential fix for Windows 8 disk issues (AMD hardware only)

Ryan Douglas

Staff member
A small number of users report an issue when attempting to install RealFlight on Windows 8, where the disk spins in their drive for 20 minutes or longer before the RealFlight installer appears.

We have no reason to suspect this problem is specific to our software. The vast majority of Windows 8 users experience no such symptoms with RealFlight, whereas some Windows 8 users do experience the same issue with other, non-RealFlight software. Still, if we can learn of a solution to help affected users, we obviously want to do so.

To that end, I am presenting here a potential solution for some of the users experiencing this problem. This applies only to users with an AMD processor/chipset.

So far we have only very preliminary information about this fix, but RealFlight Technical Support reports that it has helped 3 out of 3 people who have tried it thus far. That's enough to justify sharing it here, in the hopes that we can both gather more data about its effectiveness and help a greater number of users sooner than later.

If you do not have an AMD processor/chipset in your computer, stop here. These steps will not work for you.

Go to this support page on AMD's website. It is not clear to me whether you need to install both the chipset drivers and the RAID drivers or just one or the other (unfortunately, tech support was closed for the day when I began this post). I do know that the user who originally suggested the fix discovered it due to RAID errors in his system's event log. In any event, make sure you are grabbing the Windows 8 version of the drivers, which are all at the top of the page.

I don't see any reason these drivers can't be used in non-HP systems, but it may be worth noting that all three of the users tech support walked through these steps had an HP computer. Perhaps HP systems are just more likely to be affected?

Install these drivers at your own risk. You should make sure they are a proper match for your hardware, and consider creating a Windows system restore point and/or backing up your important data before proceeding. I'm sure they're safe when used properly, but we can't be too careful when it comes to suggesting people modify their operating systems.

If you are experiencing the problem described at the top of this post and you try this fix, please post here and let us know your results.


New member
This update totally fixed my loading issues. I downloaded both updates and everything works now.

I was ready to throw a brand new computer out the window.

Ryan Douglas

Staff member
druthomas, thank you for the feedback! I'm very glad to hear that this information worked for you.

Do you know if it was the chipset or RAID drivers, specifically, that fixed the problem for you?


New member
I experienced the same problem when installing RF6 to a HP Win8 machine with AMD processor. Like the others, had to wait about 20 minutes after each "FREEZE" but it installed finally.

On the AMD web link it states the software is for 700 series or newer chipsets. How do I find out exactly what I have so I will know if this will work for my PC? The software states: "This package is for motherboards with 700 series or newer AMD chipsets"

Brent Oar

New member
AMD Problems with install

I have a week old Toshiba L75D-A7280 With an A6 CPU and the 7280 Chipset. My DVD player will attempt to spin the disk for a second, then it tries again, then nothing. I tried the above suggestions and they have not worked. I know it is not an issue with the DVD player as it reads all other disks I have installed.

I also have 6 Month old Toshiba L875D-S7332 that exhibited the above behavior but at least I eventually got it installed. I bought the new faster PC so I could hand the older one down to my girlfriend but if I can't get this to work, she may get the new one and I keep the old one.
Help!! any other suggestions