RealFlight 5.5 freeze issue


New member
Good morning,
I have been using RealFlight 5.5 on the same pc and hardware for about 15 years, all the way back to Win XP. I upgraded to Win 98 then finally to Win10. And now I have an issue that I have never seen before, even in any previous operating systems. I will try to get as much information here as I can and see if someone else has experienced this issue. I have been using Win10 for about 3 or 4 years. I did not upgrade recently.
My pc was a bit sluggish so I decided to format the C: drive, SSD and reinstall Win10. I kept all of my programs, like Browsers, printer software and RealFlight on a separate SSD, for instance drive G: When I got the operating reinstalled it had reassigned the drive letters on all the drives. So the shortcut icons on my desktop were not good any more. I went into the properties and changed the target location to reflect the drive letter change. Did not help. I guess there was some sort of mapping to other folders that still had the previous drive letter. When I decided to uninstall RealFlight a folder on one of the other drives, that was not even related to RealFlight, just disappeared, vanished. So on the drive that the folder vanished on. I backed up the My Document folder to another usb external drive because I was afraid something else was going to happen to other folders. When I was ok with the operating system installation. I installed RealFlight to one of the other SSDs, F: drive for instance and I launched it. The program now freezes when I choose the "popout" side menu to select either aircraft or airport. The other options on the "popout" are not an issue. See attachment. If I use the Aircraft or Airport menu option at the top, its ok. It does not freeze. I tried formatting and reinstalling everything again, like 3 or 4 times. Same result. So I thought maybe it is the chipset drivers that windows is installing. The Chipset CDs will not run in Win10 they are so old. Remember, I upgraded from Win98 to Win10. That went smoothly. RealFlight worked at that time.
So, since I thought it might be the chipset drivers. I bought a WinXP install disc from eBay. I had an extra SSD. Plugged it in, installed XP on it. Activated XP, installed and updated Realflight. Started RealFlight and bam! Same issue. It still freezes. I am really miffed as to what the issue is. Oh, the inside of the PC was a little dusty. So it took my trusty air hose and blew the inside out. I have done this before. And it did not cause any issues. So there you have it. I am back to a configuration I was using 15 years ago. And it still freezes. My only conclusion. Maybe the hardware is just too old. Maybe blowing it out has caused some issue. But hasn't in the past. Any ideas or suggestions would be appreciated. That old saying, "don't fix it if it isn't broken." definitely applies here. Lol


  • Screenshot_1.PNG
    374.5 KB · Views: 3
  • Screenshot_2.PNG
    280.7 KB · Views: 3