Intel iGPU beta fix feedback thread


New member
Microsoft Windows 11
12th Gen Intel(R) Core(TM) i7-1260P, 2100 MHz
Intel(R) Iris(R) Xe Graphics / driver

Hello. I'm totally new to RF, bought it very recently (version with InterLinkDX controller). I installed the software via Steam without any problem. But when I started it I got a black screen and a message like "d3derr" or something like that. I was very disappointed... then I spent some time on internet and this forum. Here what I tried:
1. Update of all drivers via Windows Update
After that I was able to open RF but no tool bar, a plane was on the runway but not able to do anything, no activity from the controller.
2. I loaded the beta "dxvk" fix
Starting RF with the beta fix gave me an error message like "an unexpected error has occurred. Would you like to send an error report?". Answering yes or no simply closed RF.
3. I updated the graphic card driver via Intel website, using the Intel Driver & Support Assistant
When starting RF without beta fix I got again the plane on the runway but without tool bar and no control at all. But when starting it with the beta fix.... it works!!!

Thank you!


New member
RF Evolution works as it should be. Only the graphics are very bad.
At first RF did not work on my new laptop with Win11. On my ten year old laptop RF works fine, including the grapics.
Now RF works on both laptops and on both laptops the graphics are bad. Ik looks as the graphics of a game of 25 years old
RF version 10.00.049

New laptop:
devicename laptop
Processor 12th Gen Intel(R) Core(TM) i5-1235U 1.30 GHz
Installed RAM-geheugen 8,00 GB (7,68 GB beschikbaar)
Type system 64-bits besturingssysteem, x64-processor

Edition Windows 11 Home
Versie 22H2
Install date ‎27-‎2-‎2023
Build of OS 22621.1848
Windows Feature Experience Pack 1000.22642.1000.0

I hope this wil be solved soon.