Intel iGPU beta fix feedback thread

Ryan Douglas

Staff member
This thread is for users to report their results using the DXVK-based beta build described here. Please provide feedback, whether good or bad, to help us learn how well this approach works.

Does RealFlight run successfully now with no apparent graphics-related issues? Please post and let us know! If we only hear the bad, we’ll reach an incorrect verdict based on the skewed data.

Does RealFlight run better than before, but still has certain issues? Please describe what they are in as much detail as possible, including exactly what happens and when.

Is there no difference compared to the non-beta version of RealFlight? Does it still fail in exactly the same ways as before? Confirm you followed the steps properly and see “[dxvk-intel-fix]” next to the product name in your library (see attached screenshot). If so, let us know that it did not work.

Please include your basic system specs in your post. Specifically, we’re interested in the following:
  • CPU (e.g., i3-6100T, i7-13700K)
  • Windows version (8/10/11)
  • Intel driver version (e.g.,


  • Steam client_dxvk branch name.png
    Steam client_dxvk branch name.png
    49.4 KB · Views: 19


New member
Good morning. I'd like to thank Ryan and the community for the progress forward and for sharing it on here. I need assistance please with obtaining the Beta Build. After step 3, in which I select Betas on the left, a field is appearing beneath the Beta. It reads "Enter Beta Access Code to unlock private Betas." What do I type in there? There's no short download occurring. Attempting to run RF Evolution from here results in my receiving " An unexpected error has occurred. Would you like to contact the Real Flight team"? /// System specs: Intel Core i7-1255U Processor (2) ; Windows 11 Pro (67); I do not know where to look to find which driver version I have, nor do I know how to update them.
Thank you.


Well-known member
No need to do anything more, there is no code to input, just select which version you want and then hit the X in the top right of the Beta screen, you will notice the version you selected is now shown as Realflight Evolution (dxvk-intel-fix}, and if you go back and select the "None" then the name will show as Realflight Evolution (no suffix)


  • Selected version.jpg
    Selected version.jpg
    47.1 KB · Views: 23


New member
Thank you for your reply to my question above. The program appears to be getting less through the installation process than it was before. Previously, I had the red and white jet load onto the airfield, even though nothing would "move": no ailerons, no wind speed, no tilde key, etc. Now the program just stalls and stops responding during the download process. 1674752594550.png


Well-known member
i7-13700K CPU
Windows 11
Intel driver
After a couple of hours testing updated the driver to RFE working stable.
Updated again to RFE works stable.

Issues with the Beta NONE version.

Strange start up screen, camera initially zooms in on the model, so close you can see the inside of the model, then the camera zooms back out to display the airport.

All of the top menu bar (legacy) is greyed out on initial startup, until you press the Esc key to enable the menu, which turns the menu text to bold. Also, no movement with the model before ESC key is pressed.
The new style menu is unavailable.
Only two buttons on the DX work (Reset and Cancel). The Cancel only pauses the simulator, does not select the new style menu like it should.

Press Simulation tab = drop-down list is displayed.
Press Scenarios = only a small viewport opens. (No scenario options screen).
Press Controller = nothing happens.
Press Physics = nothing happens.
Press Graphics = program locks up, you must right click on the task bar icon, select close window, to exit.
The remainder of the selections in the list, from Flight Failures down to Exit appear to work okay.

Aircraft and Enviromental (Airport) all selections work okay.

Gadgets, only three work, Radio, Binoculars and viewport.

If you exit the DXVK version and have a helicopter selected, then switch to NONE dxvk version, Evolution will not start, all you get is the Unexpected Error message, click yes or no and RFE closes.
You have to switch back to DXVK version, select an airplane then exit and switch to NONE version, now RFE (NONE) will start.

Selecting any helicopter in the NONE version will generate the "Unexpected Error" message and close the simulator.

Selecting "Training", (NONE version) and any of the Heli Training options will immediately freeze the simulator, only way to close the simulator is by using Task Manager,
When you restart the simulator the "Unexpected Error" message is displayed and forces a close again, you have to restart using the DXVK Beta, spawn an airplane, now switch back to Beta NONE version, to restart the simulator.

Photofields appear okay but 3D fields display large black areas in the grass and sand.

Flight physics for airplanes, Drones and helicopter are good, frames per second with all graphics set to maximum\highest is about 140 fps, all settings reduced to low is approximately 250 fps, (1920x1080 resolution).


Well-known member
Realflight Evolution (dxvk-intel-fix) version works good using the Intel 12th or 13th generation CPU's, utilizing just the onboard IGPU, frame rates are not as good as if you were using a Discrete video card, but the flight physics and realism is enjoyable.
All of the noted issues listed in post #7 are fixed, startup screen loads normally, all buttons on the DX work as designed, the new style menu is available, all gadgets work, helicopters can be selected, and the training videos work.
Black patches in the grass or sand at 3D airports are gone, looks normal now.
During a few hours of testing, I did have a couple of simulator lockups, these were after helicopter crashes, (Dominion 3D 90 and Ucureuil Scale Head), had to right click on the task bar icon and close window. Driver
Another issue was when scrolling through the new style menu, it would reach a certain model and immediately crash the simulator, sending me back to the Steam screen where I just had to click the "Play" button again. The aircraft name in the list was an AV of a deleted model, so I browsed to the Custom Vehicles folder and deleted the associated .rfvehicle file, problem fixed.


New member
Good Morning.
The DXVK/Intel workaround fixed it and now RFE is running fine.

i5-12400 intergrated Graphics
Win 11 (22H2)
Intel driver Update from something like .11xx up to 4090 and adding the DXKV .dll do their job :)

Thank you !!!!!!


New member
I have a Surface Pro 9. 12th gen intel i7, 16gb ram, Win 11 Pro (22H2).

I loaded the beta from Steam and the Intel beta drivers .4090 worked. I have now upgraded to .4091 and continuing to work.

Will this fix be baked into a stable release soon? Thanks for your help here...

Ryan Douglas

Staff member
Thank you for your feedback. I'm glad that is working for you!

Will this fix be baked into a stable release soon?
Unlikely. While Evolution user reports have been very positive so far, it is a workaround, not a true fix. Swapping out the rendering system for our entire userbase with only limited testing is not something we are prepared to do, and the fact that the underlying DXVK implementation works at all on Windows is sort of incidental to their actual focus, which is Linux.

We're ecstatic that it exists as a means for affected users to use their software in the short term. Our plan at this time is to keep it available in a separate branch until a true fix is ready in the form of a DirectX update to RealFlight itself. That time is not quite here but it is on its way.

Dark Schneider

New member
The dxvk -intel -fix works on an all AMD system as well

Win 11
7900xtx current drivers

Program was crashing all the damn time on my system and causing complete system reboots
This beta fixed it
No crashes, no missing textures, everything works


New member
AMD Ryzen 9 3900X CPU
Sapphire Radeon RX5700XT Graphics Card
Windows 10 Pro 64bit Operating System
Newest AMD Graphics driver

System was crashing constantly. The Intel Beta from Steam fixed everything even though I have an AMD system.

No crashes or problems at all.....