Modem/Router configuration for MultiPlayer

Not open for further replies.


Well-known member
First, if you have configuration issues you'd like to discuss, please start another thread. Post screenshots there of an ipconfig dump, and your router's port forwarding page. Continue reading this post for some tips on that. Also post both your modem and router model numbers. This thread has it's own purpose. We'll help you in your thread.

To join or host a multiplayer session, you must forward ports through your router and/or modem. This topic has been done to death, but there are a few things I'd like to do here. The ports listed in the instructions pertain to G5 only. Ports for G4 are 61234-61250 UDP and 61300-61316 UDP. Ports for G3 are 6073 TCP and 2300-2400 UDP. These instructions can still be used for previous versions of RF, substituting the correct port ranges for your version of RF where appropriate. The following descriptions assume that you are using a modem that is also a router. If you have a router plugged into your modem, these instructions will work only if your modem is not doing NAT translation, but rather passing the outside IP address to your router.

First, open a command prompt. This can be done by typing 'cmd' (yes without the quotes) in the 'Run' box. See picture 1.

Type 'ipconfig' where the cursor is blinking. You'll see an output like picture 1. There are only 2 line items to be concerned with, IPv4 address, and Default Gateway. If you are using XP, the output may look different, but the 2 items will be there. Write both of these down.

Open up your browser, and where you would type a web address, type the default gateway address. In my case, it'd be This is how you log into your modem or router. You'll have a login window pop up. I can't help you with what needs to be put in there, you should know it, though. If you don't, consult your manual, there is a default.

This is where things will look quite different, due to different router models. Mine is for AT&T Uverse, with a model number of 3800HGV-B Gateway. Go to the firewall section, which may take some poking around to find.

You'll probably find a place to add a user defined definition, as shown in picture 2. In my case, I must have already selected the computer to host the application before I select adding the definition; other routers will make that setting later. Go to the screen to add a user definition. Mine looks like the third picture. You'll have to name the definition, which can be anything you like. Then plug in the port ranges, 61234-61241. Select UDP, not TCP. In my case, I left the Map to Host Port blank, but if you have to put something, put 61234. Make sure you add your IPv4 address to the computer name/IP address field, if that's how your screen is set up; mine is not like that. If your computer's IP address changes, you'll need to reset the IP address in the port forwarding page to match. If you have that problem, (I don't) set a static IP address through the network settings of your computer. If you need help with that, I'll make another post here.

Once you've added the new profile, save the settings, and then disconnect the power from the router, and turn off your computer. Turn on the router, and let the lights come back on. This could take a couple minutes. Then turn on your computer, and go to a web page to see if the router is ready. If you can get a web page, then go try to join a RF session. You may get a pop behind window that Windows firewall has blocked Radio Control Simulator. You must allow it.

This may not be the neatest sweetest way to get the job done, but it will work for the vast majority of users. If you have internet security software, you may need to create an exception in it as well.

If you have tried the above advice without success, you may have a router connected to a NAT-enabled modem. If this is the case, port forwarding is different. To test the theory, plug your RF machine directly into your modem. You must reboot your computer to receive an IP address from your modem. Look at your IPv4 address as described earlier. If it is in the range of to to to
and as of July 2001 to
then your modem has NAT enabled. The best thing to do is replace your router with a switch. Of course, if your wireless feature comes from your router, you wouldn't want to do that (and the modem must be doing NAT to allocate an IP address for a device). I have had success putting my modem in bridged mode, allowing the router to negotiate the connection.

Now, what I'm going to ask others to do, is to post the page that they use to enter in port forwarding information for other modems or routers that may not be listed here. That way, we can get a collection of screen captures that other people can refer to. If you post a screenshot, please include the model name of the router or modem, so it can be found with a search.


  • Untitled.jpg
    92.6 KB · Views: 600
  • Untitled3.jpg
    139.5 KB · Views: 669
  • Untitled2.jpg
    73.9 KB · Views: 537
Last edited:
LinkSys Wireless-N Gigabit Router (model WRT310N) with a Motorola Surfboard Cable Modem (model SB5120). The Surfboard was supplied by Cox and I added the router.


  • Linksys WRT310N.jpg
    Linksys WRT310N.jpg
    94 KB · Views: 598
Last edited:
the IP port, .21, is that your computer's IP or the router's? Reason I ask is my router defaults to .21.
Last edited:
G4 (and G5) require 2 ranges of ports, as I stated in the OP. The first range is for play, the second range is for voice chat. And his .21 is his RF computer's IP address.
Chromenut said:
the IP port, .21, is that your computer's IP or the router's? Reason I ask is my router defaults to .21.
There are two ranges to be forwarded. Yes you could make it all one, but you would be adding 50 un-needed ports in the range.

.21 is the last octet of my desktop's IP. My router's is .1 on the local net.
Here is what the D-Link port forwarding page looks like on mine. I have a D-Link DIR-655 router.


  • D-Link Router Config.jpg
    D-Link Router Config.jpg
    209.1 KB · Views: 356
Last edited:
For the Belkin 802.11G wireless router model F5D7230-4.


  • Belkin80211G setup.jpg
    Belkin80211G setup.jpg
    136.2 KB · Views: 265
Wonderful Idea!

Posting the modem configuration screens for G3/G4/G5.

Kmot: It is safe to post your private IP numbers. They are non-routable.


I'm sure many newbies will still fail tou allocate a static IP address and also not understand that they need to use this static IP in the respective fields.

But this thread looks like it will be VERY helpful for people.
opjose said:
Wonderful Idea!

Posting the modem configuration screens for G3/G4/G5.

Kmot: It is safe to post your private IP numbers. They are non-routable.


I'm sure many newbies will still fail tou allocate a static IP address and also not understand that they need to use this static IP in the respective fields.

But this thread looks like it will be VERY helpful for people.
My private IP's are within my firewall, so I could care less who knows them. Without breaking through, you couldn't ping them direct. Believe me, I've spent hours knocking on that door...
Linksys WRV54G G4/G5 configuration

Here is the configuration page that works well for BOTH G4 and G5 with all features including voice.

Note that the STATIC IP of my computer is


  • wrv54g router.jpg
    wrv54g router.jpg
    202.1 KB · Views: 436
RealFlight G5 actually only needs a total of 8 ports forwarded in order to use multiplayer. If RealFlight is left with the default base port of 61234, then you need only forward the port range of 61234-61241 UDP to your computer's IP address. The secondary port range is no longer necessary in RealFlight G5.
G5 pretty much tells you what to do if it fails.

1. You may fail during the connectivity test
2. The Error message pop-up will give you the forwarding information necessary for your router.
3. Enter that into your router's config menu (WRT610N) in my case.

Once this was done, I was able to see ongoing sessions.


  • multi1.jpg
    60.7 KB · Views: 154
  • multi2.jpg
    127.8 KB · Views: 228
  • multi3.jpg
    253.3 KB · Views: 314
Note that you can also change the port G5 uses for multiplayer in Simulation -> Settings -> Multiplayer. Most people won't need to adjust this, but it is useful if you need to resolve a conflict with another service on your computer or with another port forwarding entry on your router.
using ATT uverse

I was having a hard time getting connected as well. Turns out, I was thinking that the computer connected to the router was the one i was supposed to be forwarding the ports from. I have a multi computer home network, I was thinking that was the one the firewall stuff was. well i was wrong. I had to delete RF from that machine and just use the machine i was actually sitting at. Now it works as advertised! Duh :confused: :confused: :confused: :)
Actiontec MI424-WR router settings

This router is a bit confusing, I think, but after some "tire kicking" I found the right choices. Follow the steps below -- I've attached three images to assist you in setting things up:

1) From the main screen click "Firewall Settings"

2) Leave default choice of general and click "yes" I want to proceed

3) On the left side of the general settings page, choose "Port Forwarding"

4) On the Port Forwarding page click the "add" button in the lower left of the Port Forwarding box

5) In the Local Host "specify address" box enter the IP address of your machine (if you are unsure how to do this there is a thread elsewhere that explains all)

6) You should now see your rule in the port forwarding box witbh your IP address under "Networked Computer/Device". Click the edit button under the Action column

7) Edit the settings as in the attached image

8) Click apply, etc.. the "completed" image is how your page should look.

Good luck!


  • actiontec_add_port_forward.jpg
    86.4 KB · Views: 178
  • actiontec_edit_service_serv.jpg
    69.5 KB · Views: 124
  • actiontec_completed.jpg
    124.5 KB · Views: 140
Motorola 3347

Got it working with some help here on the forums. Port forwarding is under the "gaming" secion of the main menu. You must create a custom service (by clicking "define custom service") for real flight with the proper ports forwarding and then select the custom service (should now be at the bottom of the drop down menu) and assign it to the appropriate IP address.

Looks like this:


  • Picture 4.png
    Picture 4.png
    66 KB · Views: 102
  • Picture 5.png
    Picture 5.png
    21.2 KB · Views: 52
Apple Airport Extreme on Realflight G4.5

The thing that you can't see is, the airport extreme gets set up through an Airport Utility App.

To find ip address of the computer use these steps
1- Click the Start menu button on the Windows taskbar.
2- Click 'Run...' on this menu.
3- Type 'cmd' in the text box that appears. A command prompt window launches on the desktop.
4- In this command window, type 'ipconfig /all'.


and the default host is the computer of what realflight is on, then configure your port mapping


Just add the ports as shown, and the private ip address of the airport which is the 10.1.1 (router default)
Last edited:
Please do not post in this thread questions about router set ups. This thread is for showing successful router set ups. If you have questions about your specific router, start a new thread .

Thanks Chris McVey
Not open for further replies.